Backspace does not work (WinCE5/PB5 port)

Topics: Developer Forum, User Forum
Jul 2, 2008 at 7:00 PM
Hi all,

I'm using putty as a SSH client to the OpenSSH server - everything's working fine (including SFTP) but if you press backspace this is not passed to the cmd-shell correctly - although it optically looks good (last character removed) it seems that the shell gets another special character (backspace) instead of the removal of the last one.

So for example:
If I enter
    CMD<BS><BS>D \windows<CR>
this cannot be interpreted by the shell...

Does anyone have similar experiences?
Is there something I can do about it (configuration)?

Thanks
Martin
Jul 3, 2008 at 4:26 PM

Hi Martin,

Where did you get the WinCE5/VS2005 solution files?  I tried the binaries without any luck, and my porting effort has turned into a failure.


mpauly wrote:
Hi all,

I'm using putty as a SSH client to the OpenSSH server - everything's working fine (including SFTP) but if you press backspace this is not passed to the cmd-shell correctly - although it optically looks good (last character removed) it seems that the shell gets another special character (backspace) instead of the removal of the last one.

So for example:
If I enter
    CMD<BS><BS>D \windows<CR>
this cannot be interpreted by the shell...

Does anyone have similar experiences?
Is there something I can do about it (configuration)?

Thanks
Martin



Jul 4, 2008 at 7:50 AM
fondue wrote: Where did you get the WinCE5/VS2005 solution files?  I tried the binaries without any luck, and my porting effort has turned into a failure.

I'm sorry - my fault... I meant WinCE5/PB5.
I used the platform builder 5 to compile this project as it is initially intended - if you need help with that I'm open to assist, just let me know where it fails...

However I'm still struggling with the backspace... :-(

Thanks
Martin